
Interactive plot is used for the viewing and optional plotting of acquired data either recorded as depth or 
time. Interactive plot is normally started from Acquisition by clicking on Action -> Record Up, or optionally 
Record Down or Record on Time. How the data is presented is initially controlled by the presentation that 
has been selected for each separate service. Note that even if interactive plot is closed that data continues 
to be acquired and recorded until the Action -> Stop command is invoked from acquisition.  
 



 Fig. 7.1 Starting Interactive Plot from acquisition 
 
Multiple instances of Interactive plot may be opened at the same time showing the same data with different 
presentations or with different passes of data even if they are not from the same database. To start an 
addition instance of Interactive plot from Acquisition, click on Action -> Replay or optionally Independent 
Replay. Replay will allow the user to view any previously recorded pass within the current database open in 
Acquisition, while Independent Replay allows the User to select a different database and open any pass 
within that database. 



 Fig. 7.2 Invoking additional instances of Interactive Plot from Acquisition. 
 
Independent Replay functions the same as if Interactive Plot were started from the Warrior Software group. 

 Fig. 7.3 Starting Interactive Plot from the Warrior Software group 

  
 
If Interactive Plot is started from the Acquisition window the data will normally be immediately displayed on 
the screen. When Interactive Plot is started from the Warrior Software group no presentation is shown 
because the data to be displayed has not yet been selected. To select the data click on File -> Select 
Dataset . . . The User can then select a database file and then select a pass from that file. At that point, the 
data may still not be displayed on the screen.  



 Fig. 7.4 Interactive Plot File Selection 
 
To display the data click on Action -> Screen Plot or click on the monitor icon (third from left).  

 Fig. 7.5 Displaying selected data 
 
7.1.2  Interactive Plot  File Selection  ASCII Data 
  
ASCII data files can be imported into a Warrior database by selecting the File -
selection. The existing database that has been selected can be written to an LAS file by selecting the File -

 
Refer to the Database Utilities section 13.x.x 
 
7.1.3  Interactive Plot  File Selection  Exit 
 
The current active Interactive plot may be closed by click on File -> Exit. All Interactive plots that are open 
many be closed by click on File -> Kill ALL Interactive Plots. 
 
 
 

  
 
The Options selection of Interactive Plot allows the User to change the presentation of the current database 
pass selected. These options include the start and stop depths of the presentation regardless of the range 
of the acquired data. The format presentation file used to present curve data can be chosen. The vertical 
scale of a log pass can be set to certain standard values.  The depth can be shown as either English Units 
of feet or Metric units of meters regardless of the units that depth was set at when the log was acquired. 
The data displayed can be shown as English units, Metric Units, or a mix of User defined Units regardless 
of the default unit selection shown in the Warrior Control panel for acquiring data. The scrolling rate of the 



data can be selected so that if the plot screen is updated it will scroll quickly in the fast speed and more 
slowly in the normal speed. 
If the check box  
format presentation will only effect the passes in the current database that is being used. If the box is not 
checked, than any changes to the format presentation will be written to the presentation file that is saved in 
Warrior\Format folder and will be in effect when a new database is used. 

 Fig. 7.6 Interactive Plot  Plot Options 

  
Edit from Interactive Plot allows some addition features to be added to a log pass and also invokes some 
programs that can be accessed elsewhere.  
 
7.3.1  Interactive Plot  Edit  Log Format 
 
The Log Format selection will open up the Format Editor with the presentation for the current pass. If the 
pass is using a Private Copy of the presentation, it will be the private copy that is being edited. See section 
6 for more detail on the Format Editor. 
 

 Fig. 7.7 Interactive Plot  Edit selections 
7.3.2  Interactive Plot  Edit  Annotations 
 



The Warrior software allows the user to place annotations or text on the plot. By clicking on any of the text 
shown in the three windows, the text selected will be placed in the bottom text box. The User can also type 
any text that he wants into the text box. 
When the text has been entered in the text box, click the first icon, that looks like an arrow with an ab (<ab). 

 Fig. 7.8 Annotate Window 
 
Now move the cursor across to the plot. You will see an arrow with abc. Position the tip of the arrow on the 
plot where you want the arrow of the annotation to be and then left click. If you right click, the direction of 
the arrow will rotate through left, up, right, down, and then two modes with no arrow. As long as the <ab 
icon in the Annotate window is active (shaded dark), every left mouse click will add another annotation to 
the plot. To change text, move to the annotate window, change text, move back to the plot, right click to set 
arrow direction and then left click to add the next annotation. 
 
Once placed on the plot, annotations positions can be changed or the annotation can be removed. In the 
annotate window, select the <ab icon so that it is not active (all icons have the same shading). Move the 
cursor back to the plot and click on the desired annotation. When selected it will show as black with white 
text (it may be necessary to pause the plot to be able to select the annotation). You can now right click to 
change arrow orientation and then left click to move it to a new position. To remove the annotation, check 

-> 
 

Delete key on the keyboard. 
 
There three groups of default annotations shown in the annotate window. The first group are text that 
appears in the annotate window no matter what is plotted. The second group is Warrior database 
mnemonics for all of the Database items that are in the presentation. 
for the mnemonics in the second window and all of the labels that are used on the curves.  
The list of curves in the first group can be edited and the translations can be chan -> Edit 

Warrior\config\annotate.ini. 
 



 Fig. 7.9 Annotate File selection 
The [Always] group must be a sequential number list that contains the text that the  User wants. The order 
can be rearranged and items added as long as the list remains sequentially numbered. 
The [Translations] group allows for common labels to be shown for Warrior mnuemonics used in the 
presentation. For example, if GR is in the current presentation, the translation Gamma Ray  will show up in 
the third window of the annotate window. 

 Fig. 7.10 Annotate.ini file 
The second icon in the annotate window allows the user to place a graphical image onto the plot. The third 
icon is for vertical text, but is currently not functional. The fourth icon will place a horizontal bar on the plot. 
The fifth icon has no function. The graphical image and the bar are placed and removed in the same 
manner as text. 
 

Annotations are place at a depth and horizontal position on the plot. This mean that if 
the presentation is changed, the pass is depth shifted, scales changed, or anything 
that would affect the position of the curve data, annotations are not moved and do 



not necessarily point to the curve that they originally pointed at. 
7.3.3  Interactive Plot  Edit  Log Banner 
 
Log Banners are additions that can be attached to a log pass. The banners may be placed at the top and / 
or bottom of the log pass. Click in the area where the text will appear and type in the desired text. When 
finished, click on File -> Save and then File -> Exit. 

 Fig. 7.11 Edit Log Banner 
 

 Fig. 7.12 Entering text in log banner 
 
Log Banners are very similar to headings in that they are a text file with a .WLB extension that the User can 
easily edit. There are several variations that are supplied with the Warrior software. To select a different 
style, click on File -> Select Format. The Select Banner Format window will open shown the banners that 
are available in the Warrior\Format folder. 
 



 Fig. 7.13 Log Banner File Selections 
 
Once the banner has been saved and the banner editor closed, the banner does not appear on the screen. 
However, when the log pass is printed through Interactive Plot or as part of a Plot Job, the banners will be 
included as part of that pass. 
 
7.3.4  Interactive Plot  Edit  Well Sketch 
 
The Well Object Editor allows the user to show certain well objects on the plot that would represent a well 
bore configuration. These objects include but are not limited to strings of casing and tubing, plugs, packers, 
and nipples. To be able to see the well objects once they have been configured, the presentation must 
contain WELLOBJ as a Graphic Strip. 
Any track may be used, but the graphic strip will cover the width of the track regardless of the left and right 
values used. 
 

 Fig. 7.14 WELLOBJ plotted as Graphic Strip 



 
It is not necessary but if the wellbore gets complicated with multiple strings of casing, the first thing to do is 
sizes can be entered as the dimensional values that they are. Measurement units for Depth and Object size 
can also be set from here. 
 
 
 

 

  
Fig. 7.15 Well Object Editor Menu and Toolbar and Settings 
 
The object that an icon represents can be identified by holding the mouse cursor on the icon. To 
demonstrate the well sketch we will do an example. We will start by going to settings and setting the width 
of the diagram to 8.625 . Next we will click on the Casing Icon. 

 Fig. 7.16 Identifying Icons 
 
the depth interval from 0-105, and the width of object as 7 inches. Notice that the Horizontal positions are 
automatically adjusted to fit the diagram and casing size. Click [OK] to save that string of casing.  

 On this string we are going to check 
e BONDIX to show 

shading as a representation of bonded pipe. 
The last string of casing will be put in as a liner from 1550 -
bonding on this string. 



 Fig. 7.17 Entering casing depths for stings of casing 



 
s put a bridge plug and packer into our well. We want to 

but the problem with a single depth entry for plugs and packer is that it centers the image at the depth. So if 
you want the top of the plug or packer to 
good even if the plug is not that long) in this case 1800-1805. At the same time we will enter an annotation 

 

   
 
esthetically pleasing, the tubing should fit the hole in our packer. The hole in the packer is 1/3 the width of 
the packer. Since we set the packer in 5 ½ the tubing should be 1.84. As long as we are at it, let s put a 
seating nipple in the tubing at 1565  



  
  

 
The last thing that we want to do to our well sketch is to add some perforations. Zones are entered by top 
depth, a hyphen (or minus sign), and bottom depth. Multiple zones can be entered by separating each 
zone with a space or comma. Single shots can be entered by putting just the single depth. In the example 
below we have zones from 1630-1640, 1650-1655, and 1660-1667 with a single shot at 1683.  
Use the left% and Right% to position the perforations. The default is 0 and 20. In this example, that puts the 
perforations into the area where the bond index is shaded and makes them difficult to see. Since the 4 
casing starts at 17.9%, I started the perforations at 18% and kept them 20% wide. This puts them inside the 

 
 
Just as an example, I have also added some squeezed perforations, that use a slightly different image than 
normal perforations, from 1630-1680. I positioned these at -20% to 0% to show that well sketch images do 
not have to remain in the track that the WELLOBJ image is place. Any percentage can be used, but it is 
based on the track that the WELLOBJ image was placed in. 



 

 Fig. 7.20 Entering Perforations 
 
Annotations that are adding from the well object will always be placed in the middle of the object. Should 

- Interactive Plot and then 
move them. 
 
Well Sketches are kept by runs. So every pass in a run of a dataset will have the same well sketch. If the 
User want to have different sketches, they must be entered in a pass on a different run number. 
(/field/well/run1/pass1  and /field/well/run1/pass2  would have the same well sketch while 
/field/well/run2/pass3 could have a different well sketch) .  
 
It is possible for the User to create their own well objects to be used in a well sketch, but it is outside of the 
scope of this document. If this need  



 Fig. 7.21 Well Sketch example image 
 
7.3.5  Interactive Plot  Edit  Log Heading 
 
Clicking on - Plot invokes the Heading Editor. See Section 5 for a 
discussion of the Heading editor. 
 
 
7.3.6  Interactive Plot  Edit  Multi-File Plot Job 

Clicking on -> Multi- from Interactive Plot invokes the Plot Job Editor. See Section 9 for a 
discussion of the Plot Job Editor. 

7.3.7  Interactive Plot  Edit  Zoned Scale Changes 



Zone scale changes allow the User to display curves with different scales in different parts of a pass and to 
shut the curve off if desired. If the current presentation does not have any curves that have been enabled 
for zone scale changes, a warning will come up to notify the User. If the [Yes] button is clicked, the Format 
Editor will open with the current presentation. 

 
Fig. 7.22 Zone Scale change invoked with no zoned scale curves 
With the Format Editor open, click on the curve that you wish to have the zoned scale changes, then click 
[Change]. Check the box for Zonable Scales, then click [OK]. Save the presentation in the Format Editor 
and Exit. 

 
Fig. 7.23 Setting up Zoned Scale changes in Format Editor 
Now when Edit -> Zoned Scale Changes is selected, the zoned scales window for the pass will come up 
with any zonable curves show. In this case GR and LTEN are shown, each with a left scale value and a 
right scale value. The only zone that is shown is from the top of the pass to the bottom of the pass. To 
create new zones, click on the [Zones] button. We are going to put in a zone change at 1750, type 1750 
zone change in at 1700. 



 
Fig. 7.24 Zoneable Scales 
Now we need to edit the scales in the different zones. From 1750 to bottom, we will leave them unchanged. 
From 1700 to 1750, we will make it 0 on the left and 100 on the right. From top to 1700, we will set both left 
and right values to 0 to turn off the curves. Once the scales have been edited, click the [Accept] button to 
complete the changes. Click [Close] to close the Zoned Scales window. 



 
Fig. 7.25 Scales changed on zones 
Zoned scale changes do not automatically refresh the Interactive Plot to show the changes. To refresh the 

-  twice or click 
the Screen Plot Icon twice. Fig. 7.27 show the same log pass before and after the scale changes that we 
have done in this example. 

 
Fig. 7.26 Refreshing the screen with Screen Plot 



s 
7.3.8  Interactive Plot  Edit  Gridline Setup 

Edit -> Gridline Setup from Interactive Plot invokes the Gridline Setup editor to allow the User to control at 
what plot scaling the different horizontal (Depth / Time) grid lines appear. If the vertical scale resolution on 
the plot is less than the maximum compression ratio, and the scale resolution is greater than the minimum 
compression ratio, than the gridline will be plotted. Separate gridline setups can be kept for English depth, 
Metric depth, and a time log. 



 
Fig. 7.28 Gridline Setup 
7.3.8  Interactive Plot  Edit  Correlation Curves 

Selecting correlation curves allows you to plot a curve(s) within a pass in a database into all other passes of 
the database. You will be given the option to select a curve or curves. Highlight the curve and select add.  
Once the curve has been added to the list of correlation curves, click on the selected Correlation curve.  
There are two radio buttons. The first one, , will place the 
curve in the same track as the pass it originated in, with the scales as shown above it. This is the standard 

e is plotted, 
pass to be plotted, it will use the same scales and track as the current pass but will apply the color selected.  



 
Fig. 7.29 Setup of correlation curves 
If the displayed pas is depth shifted, the data in the pass will be shifted as usual but the correlation curve 
displayed will show the depth from its original pass and not be shifted. 
There are now some additional options in Interactive plot. The default setting for correlation curves is to 
show the correlation curve, but do not plot the correlation curve in any hard copies (or PDF and TIFF). 
There are options to both display and print the correlation curves and to hide the correlation curves. 

 
Fig. 7.30 New options for correlation curves 
7.3.9  Interactive Plot  Action  Screen Plot 
After a pass in a database has been selected, Action -> Screen Plot will display the pass on the screen. It 
may also be used to refresh the screen plot by selecting it twice. The first selection of Action -> Screen Plot 
will clear the 



plot from the screen. The second selection will once again display the plot on the screen. Clicking on the 
Monitor Icon will have the same effect as Action -> Screen Plot.

 
Fig. 7.31 Action -> Screen Plot and Screen Plot Icon 
7.3.10  Interactive Plot  Action  Print 

By clicking on the Plotter Icon or Selecting Action -> Print, the Start Plot Window will open. Printing may be 
started at any time, if it is direct printing (normal mode using Warrior Printer Drivers and not through 
Windows). Even though the screen may have acquired data for a considerable length of time, the plotter 
will start at the beginning of the plot and print the log until it has caught up. Any changes made to the 
presentation while plotting may have unexpected results on the hardcopy. 

 
Fig. 7.32 Action-> Print and Print Icon 
 
The User has the option of selecting which of the installed printers to send the hard copy to by clicking the 
dropdown installed printers list. There is a check box to set the currently selected printer as the default 
printer so that it will be shown when the Start Plot window is opened. 



 
Fig. 7.33 Installed printer list 
The User has the option to print multiple copies of the current plot by increasing the copy count. Most 
printers have some selectable settings that can be configured through the Warrior Software by selecting the 
[Setup] button. Due to the variety of plotters and settings, we will not cover the possible settings at this time. 
The [Top of Form] and [Advance] buttons will perform those functions when clicked. The [Calibrate] button 
allows the user to adjust the vertical scaling of the plot so the matte length meets required specifications 
(i.e. 5 inch of plot per 100 feet of well). 

 
Fig. 7.34 Calibration of printer 

 For the 
ts. The further apart that 

the two points are the more accurately (relatively) you will be able to measure the distance. As an example, 
distance 15 inches. Then if you measure it and it is 14 and 15/16 of an inch, your measured distance would 
be 14.9375. When the values have been entered, click the [Calibrate] button. The new calibration will then 
be shown. This value should be somewhat close to 1.00. If it considerably different, it may be necessary to 
remove printer scaling calibrations and start over by making a new plot. To remove plotter calibrations, click 
the [Undo Calibration] button. This will set the plotter calibration back to 1.00. 

 
Fig. 7.35 New plotter calibration saved 



7.3.11  Interactive Plot  Tools  Depth Shift a Curve 
 
The Warrior Software has the ability to depth shift a single curve in a dataset while keeping all of the other 
curves at their current depths. It should be noted that while this feature does exist it should not be a general 
practice to need to do this. Tool offsets should be adjusted to insure that curves are on depth. Depth Shifts 
to a data item or curve can be done in Interactive Plot or Database Utilities. 
The first step is to select the data or curve to shift. Click the [Select Data] button to bring up a list of data 
items in the database. Be aware that all data in the database will be shown, not just the data from the 
current pass that is displayed if you are in Interactive plot. Find and select the curve and click [OK]. Now 
enter the amount of shift with negative amounts shifting up 
checked, the encoder depth will also be moved by that amount when the [Apply] button is clicked. If you are 
in Interactive Plot, the screen will be refreshed with the curve shifted. 
No records are maintained of which curves have been shifted or by what amount. It is a good idea to make 
a backup of the database before doing depth shifts in case of operator mistakes. 

 
Fig. 7.36 Depth Shift a Curve 



7.3.11  Interactive Plot  Tools  Depth Shift a Whole Pass 

The Depth Shift Icon or Tools -> Depth Shift a Whole Pass can be used to depth shift a pass to put it on 
depth with other logs or passes. This can also be done from Database Utilities. If done from Interactive Plot, 
the current pass displayed will be sele
that you wish to shift the pass in feet or meters and click [Apply]. The Interactive plot will refresh the screen 
with the shifted pass and the encoder depth will be adjusted at that time. 

 
Fig. 7.37 Depth Shift a Whole Pass 
7.3.12  Interactive Plot  Tools  Run TVD/Merge Program 

Clicking on Tool -> Run TVD/Merge Program from Interactive Plot will open the Warrior Merge Program. 
See section 11 for information on the use of the Warrior Merge program. 
7.3.13  Interactive Plot  Tools  Create an Alias 

Creating an alias allows the User to display data in a presentation from a different pass in the same 
database. It does not create a copy of the original data but simply shows the data as being in the pass 
while it actually exists elsewhere.  
Use the [<<Browse] button to select the pass that contains the original data. That data item will then be 
displayed in both the existing data item name and the New Name fields. The New Name field must now be 
edited to show the pass and curve name that you wish to present. This normally will consist of changing the 
pass number and often changing the curve mnemonic since two curves of the same name cannot exist in a 
given pass. Verification of the creation of the alias will be shown at the bottom of the window. Note that 
when the alias is created that it will need to be in the presentation to be displayed and if it is in the 
presentation the screen may need to be refreshed before it is displayed. 



 
Fig. 7.38 Creating an Alias of GR from Pass1 as GR_1 in pass2 
7.3.14  Interactive Plot  Tools  Run AutoMerge Utility 
 
The AutoMerge Utility allows the User to merge data items of the same name from multiple passes within a 
database into a new pass and automatically gives each of the data items a new name. This is very useful 
when several passes have been run over the same interval and you wish to see all of the passes on one 
plot. The new output pass will automatically be named ./././merge1, but this may be edited. The User may 
use the [<<Browse] button to select a presentation to use on the pass that is created. 



 
Fig. 7.39 AutoMerge Utility 
 
There are a variety of naming methods that may be used for the curve names. A list of some choices and 
the resulting name for a GR from pass2 are: 
Original pass name    GRpass2 
Original pass number  GR2 
Run number and first pass letter GR2p 
Run number and pas number  GRr1p2 

 
Fig. 7.40 Curve rename options in automerge utility 

7.3.14  Interactive Plot  Pause / Unpause 
 
The Pause selection is used to keep the display from scrolling so that data may be examined, annotations 
added to the pass, etc. If the pass has been paused, the selection will change to Unpause and can be used 
to allow the display to once again scroll.  


