6 Format Editor

The Format Editor allows the creation and editing of the log presentation or format files. The output of the
format editor are files of the type *.prs which are subsequently used to control all aspects of plotting
acquired data. The Format Editor may be started in three different ways: From its icon in the Warrior
program group, from the Edit menu of the Acquisition or Recalculation modules, or from the Action menu
of Interactive Plot. In addition, double-clicking in the scales area of the Interactive Plot window will also start
the Format Editor.

When started from the Warrior program group the Format Editor window will open with no presentation
available for edit. Any presentation that is opened from there will be opened in Master Format mode so that
any changes that are made will be permanent. If started from the Acquisition or Recalculation the Master
copy of the presentation as declared in the current logging service will be opened. For Interactive Plot
modules, the log format currently being used will be presented.
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FIG: 6.1 Select Format Editor from Warrior program group
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FIG: 6.2 Select Format Editor from the Acquisition window

Correlation Curves

When the Format Editor is opened from the Acquisition or Recalculation window, the format specified in the
current service in the services.ini file is opened in the Master Format mode. Any changes that are made will
be permanent to that Master Format. If a private copy of a presentation using that format has been saved to
a database, no changes will be made to the private copy.
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FIG: 6.3 Seleéf Format Editor from the Interactive Plot window

The Format Editor can be opened from three different places in the Interactive Plot window. If you click Edit
-> Log Format..., Click on the second icon on the Presentation Plot screen, or double click on the log
scales, the Format Editor will open to the current presentation format.

When the Format Editor is invoked from Interactive Plot, changing the log format and saving it causes the
active screen plots to be re-plotted with the new format. Note that many screen plots may be overlaid on
each other at any one time. If a large number a plots are present, a noticeable delay will occur while all are
re-plotted.

Before going any further we should discuss the difference between a Private Copy of a presentation and a
Master Copy of a presentation. The Master Copy of a presentation is a file kept in the Warrior\Format
folder. When a log pass is started from Acquistion, normally a copy of this file is placed into the Warrior
database. This becomes the private copy that will be edited any time the format editor is opened from the
interactive plot. Whether the private copy is used in a service or not is controlled by the service. In the
Service Editor, there is a box “Use private copy of a presentation for all logs from this service”. If this box is



checked then the private copy will be placed in the database. Otherwise, the will be no private copy and the

master copy will be used at all times. It is recommended that the “Use private copy of presentation for all
logs from this service” box be checked in all services.
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FIG: 6.4 Selecting Private copy of presentation in the Service Editor

When Format Editor is opened from the Warrior Program group, no presentation is shown. To edit a
presentation, you must first select a presentation and open it. To do this, click on the [Open] button. Or build
a presentation from the beginning, including the grid layout.
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FIG: 6.5 Open Format

This will display a file selection window showing all the presentation files, currently available, within the
system. The operator can select the presentation file to be edited. Note that all presentation files are to be
found in the \warrior\format directory and have a prs extension.
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FIG: 6.6 Select Presentation Format to be Edited

From the Acquisition or Recalculation modules select Edit -> Master Log Format. The log format specified
in the currently selected service will be presented. Note that when the master presentation is edited, if a
private copy of the presentation has been created in the dataset, changes will not be made to the private
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FIG: 6.7 Select Master Log Format

6.1 Editing a Log Format

The Format Editor provides the User a means to graphical display data. Any data or variables in a pass,
either recorded or imported from external data, can be displayed using one of a number of different layout
presentations, or the User can create his own layouts. Fig. 6.8 below shows a sample presentation for a
radial bond log.
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FIG: 6.8 Example presentation

6.1.1  Editing a Data ltem

To edit the plotting parameters of an existing curve, click on the curve shown and then click the [Change]
button. Optionally, if you double click the curve it will also open the Define Data Item dialog window for
curve editing.
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Fig. 6.9 Define Data Item dialog window for curve editing.

The DB Item should be a valid Warrior Data Mnumonic or Warrior Variable but the software does not check
to see if the entered DB Item is valid. If the DB Item does not exist in the current pass, the software sets up
the DB Item named to be plotted but no curves or curve label are shown in the plot.



If the Format Editor is invoked from a Presentation Plot there will be a [Current Pass] button under the DB
Item entry box. Clicking on the [Current Pass] button will show a list of all of the plottable items in the
current pass. The [Quick Pick List] provides a list of commonly used DB items, but is by no means a

complete list of possible DB items.
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There are three basic types of DB items that can be plotted. The most common is a data item that is usally
an output. Any of the log variables may be plotted as a variable. The list type would be an array of curves or

the same type such as caliper arms or sector amplitudes.
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Fig. 6.11 DB Item Types

The curve may be put into any track that is defined in the current grid layout as shown at the bottom of the
window. Note that the track numbers do not necessarily conform to any API standard. The track number
can be changed by typing in the track# window or by using the scroll bar buttons next to the window. The
presentation may use any of the predefined layouts or the User may edit or build his own layouts, as will

be discussed later.



i~ Position

= Left value ]D
Track # 11_—1 _
__v_! Right value 100
Presentation Type .
JcerTH] |

(s D EDERORED

Fig. 6.12 Assigning curves to a track

The presentation type to be plotted will depend upon the data that has been selected. Most data and
variables will be plotted using a curve or a Tabular list of the data. Waveform data will normally be
presented using a Variable Density or Signature.

Pattern strips represent the values using a color pattern. Certain items such as Well Objects are plotted as
a graphic strip. Caliper arrays can be plotted as a 3D image. Caliper cross sections and other items would
be plotted as potato plots.
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Fig. 6.13 Presentation types

6.1.1.1 Plotting Data Item as a curve

When a data item or variable is plotted as a curve, there are several other options besides the track and the
scale values. These options include the color of the line, the thickness, and the dash pattern.

The curve may also be plotted logarithmically between the scale values (Note that curves are plotted
regardless of the grid layout that is in that track).

The Wrap option allows a curve to re-enter the track from the opposite side if it has exceeded the scale
value.

Zonable scales allows the user to set the scales to different values through different depth intervals on the
log pass. The values and depths are entered through the “Edit -> Zoned Scale Changes ...” option in
Interactive Plot.
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Fig. 6.14 Curve Style Options

6.1.1.2 Plotting Data Item as a Tabular Value
Scalar database items and variables may also be plotted as tabular data. The track is selected from the
Grid Layout as before, but in this case the scales are not used. The color chosen will be the color that the
tabular text is printed. The tabular data can be plotted in the left, middle, or right position of the selected
track. The number of decimal places to be shown can be selected. If the data is plotted by interval, the
interval between samples shown on the log can be selected. If the data is plotted by data, the delta change
of the data can be selected, with the data being displayed whenever the amount of change has been
reached. As with plotting a curve, the label may be changed from the Warrior mnemonic and whether the
label and units are shown on the scale inserts can be selected. The Range, like the scales, is not used in

this instance.
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Fig. 6.15 Tabular Listing Style Options

6.1.1.3 Plotting Waveform Data Item as a Variable Density



Database items that are digitized waveforms can be plotted as either a Variable Density or as a Signature.
The track is selected from the grid layout in the normal manner. The left and right scales are the sample
times in microseconds. If scale values are selected that are out of the digitized range of the data item, then
the maximum digitized value is used.

When waveforms are plotted as a variable density, normally the Percentage of the waveform windows
maximum size is used. The Percentage of Black level and White Level set the levels to change to the last
shades of the color map. As an example, if the color map had black, white, and three shades of gray
between them, and the percentages were both set to 40%, then when the signal height gets greater than
40% or 1.0 volts positive the signal will be black, between 40% and 20% the first shade of gray, between
20% and -20% the second shade of gray, between -20% and -40% the third shade of gray, and at greater
than -40%, or 1 volt negative signal, will be white. The percentages should be kept approximately equal if a
small number of different shades are in the color map to keep the baseline in the middle shade. Note that
by lowering the percentages, this in effect increases the contrast of the signal, making very small signals
visible.

Constructed waveforms made from array of data, such as sector maps made from the individual sector
amplitude data, may also be plotted as a variable density. In this case, if Specific Values is chosen, then
the calibrated output value of the data is used to set the upper and lower limits. If we use limits of 10MV
and 60MV and a map with black and white and three grays, then when a sector amplitude is less than
10MV, that section of the map will be black. When a sector amplitude is between 10 and 23.3, the first
shade of gray will be shown. When a sector amplitude is between 23.3 and 36.6, the second shade of gray
will be shown. When a sector amplitude is between 36.6 and 60, the third shade of gray will be shown.
And when a sector amplitude is greater than 60MV, that section of the map will be white.

In addition to the options for labeling the scale insert as before, the User has the option to show the
mapping in the insert or not.
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Fig. 6.16 Waveform Variable Density Style Options

6.1.1.4 Plotting Waveform Data Item as a Signature

Waveform data can also be plotted as a signature. The scales are the time in microseconds of the
waveform capture as with a variable density, and are limited by the actual time of the capture.

The User has the options of scaling the relative height of the waveform in the presentation and the interval
of how often the curve is plotted. The interval is in the units of the log, feet or meters. The positive portion or
the negative portion of the waveform can be selected for shading. The waveforms can also be presented
using a logarithmic gain and / or with waveform maximum readings all normalized to the same value. The
position of the waveform in the track can be shifted by entering a Vertical Skew value in the depth units.
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Fig. 6.17 Waveform Signature Style Options

6.1.1.5 Plotting Data Item as a Pattern Strip

Data item may also be plotted as a pattern strip. Rather than plotting a curve, the data is shown as a band,
or strip that changes shades or colors to indicate relative value across the whole width of the track that it is
plotted in. The left and right values are the maximum extents of the color map used for shading. The last
colors of the color map are used if the scale values are exceeded. An example of a bond amplitude curve
used to indicate good bonding or poor bonding is shown in the figure below.

It is possible for the shading to be composed of one of the 25 different shading patterns that Warrior
Software uses for the shading of logs. However, at the present time this requires hand editing of the color
map in the Warrior.INI file. If this should be needed, contact Scientific Data Systems for further instructions.
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Fig. 6.18 Plotting Pattern Strip

-
e -—
-
2300 = = Z —
nU
= e 2850 =2
- - i
| = o]
2850 e kel L ETES e
= e i
i:— oy ::::::::
= — | e 5l
2900 = L ek
2050 q i
i
] g
ki 4
bs
3000 C_ l'\.
2000 e
H
e -~
TX ¢
s LY
ES ‘

Fig. 6.19 Example Plotted Pattern Strips for Amplitude data

6.1.1.6 Plotting a Graphic Strip
Graphic strips are used to plot well objects created by the Well Object Editor. These are normally created
by using Edit -> Well Sketch. The allows the User to create a Well Sketch containing perforations, plug,



packers, tubing, etc. and placing them in any defined track in the grid layout. The DB Item selected to be

ilotted is WELLOBJ.
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Fig. 6.20 Plotting a Graphic Strip

6.1.1.7 Plotting a Image 3D

A graphical 3-dimensional image can be plotted in the specified track. This is usually a representation of
something like the casing taken from the readings of a multi-fingered caliper log. The left and right scale
values are not used in this instance, the scale values shown are taken from the image properties. Click on
the [Image Properties] button to open the image properties dialog.

By clicking on the [Edit Variables] button, the Casing O.D. and Casing I.D. will be updated. These variables
are what set the shown left and right scale values of the presentation.
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Fig. 6.21 Plotting a 3D Image
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Fig. 6.22 Plotting a 3D Image — Image Properties

6.1.1.8 Plotting a Potato Plot
A potato plot is used to plot a graphical image such as a cross-section diagram from a multi-fingered caliper
or a dipmeter histogram. As with a 3-D image the image is placed in the appropriate track, but the scales
have no relevance.
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Fig. 6.23 Plotting a Potato Plot
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Fig. 6.24 Potato Plot Presentation options

6.1.1.9 Plotting a List Item

By selecting the List data type, the user may plot a list of curve that are sequentially numbered and have
the same prefix ( caliper arms — RO, R1, . . . and Sector Amplitudes — AMPS1, AMPS2, ... as examples) as

a single presentation entry.

The track # needs to be a valid grid track as before. The scales values should be selected as if a single

curve were to be plotted in the track.
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Fig. 6.25 Plot a List of Curves

When you click on the [Curve List Properties] button the Curve List Editor dialog

window will come up.
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Fig. 6.26 Plot a List of Curves Properties

By clicking on a curve name or mnuemonic, the list of related curve names will be shown with the *
appended as a wild card character(s). The style for thickness, dash pattern, color, and other selections are
chosen as normal with the expection that the selected style (exceot for color) applies to all of the curves.
Every nth curve may be selected to have a differnet color other than the base color selected in the style.

The offset between each curve can be entered to separate the curves in the presentation. The offset has
several effects. As an example, let us say that the original left and right scale values are 0.0 and 10.0, and
we use and offset of 1.0. Each time an additional curve is picked up the presentation changes by the
amount of the offset. When the first curve is added, the overall track scaling changes to 0.0 to 11.0, with the
first curve plotted from 0.0 to 10.0, while the second curve is moved or by the the offset of 1.0 and then
plotted from 1.0 to 10.0 making the total track width of 11. When the second curve is picked up, the
effective grid scale changes to 0.0 to 12.0 to accomadate the additional 1.0 offset of that curve. This
continues untill all of the curves that are chosen are picked up by the presentation. Although each curve is



plotted to the left and right scal values specified, the overall scales of the grid itself are the scale width plus
the number of curves minus one times the curve offset.

6.2 Format Editor - Grid Layout

The grids or mattes that are used in the Warrior Software are extremely flexible. 20 different styles of tracks

may be placed anywhere on the page. The layout is not a fixed width so that when the plot is printed it will

fit on whatever width paper is used in the plotter from narrow 1 track plotters up to 17” or wider plotters.

To choose a different layout, click on “Layout’ and the available list of grid layouts will drop down. Click on

any of the layouts available, and that layout will then be shown at the bottom of the Format Editor window.

When the new layout is chosen, the track numbers as shown in the format editor may change significantly.

This may cause many of the data items plotted as curves to lose their assigned tracks. It is a good idea to

check at least one curve as this will show where all of the curves would be plotted.
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Fig. 6.27 List of grid layouts available

6.2.1  Format Editor - Grid Layout Editor

Even with the supplied list of grid layouts, it would be impossible to have a list long enough to
accommodate all of the possibilities of layouts the might be desired. To this end, the User has the ability to
create and save his own grid layouts. At the bottom of the layouts list is the Edit Layout option. Click on Edit
Layout to bring up the Layout Grid Editor.

There are two modes that the Layout Grid Editor can be entered. The first is a custom mode that allows the
grid layout in the existing presentation to be edited. This mode is entered by as soon as the Format Editor



is opened clicking on “Layout -> Edit Layout”. The second mode allows you to edit the Master Layouts list
that shows all of the available layouts. This allow the User to Rename layouts, Delete layouts, change the

order of the list by moving the layouts, and to copy an existing layout and giving the copy a name thereby
creating a new layout.

ile  Grid Layout  Trac ile  Grid Layout Track
Grid Tiles Tracks: Left Right Color Grid Titles Tracks Left Right Color
- 0 [0 [Wbiack - o 30
b 3 Track Linear, Track 3 Clear b s
c Redra 3 Track Linear, Tracks 2 &4 3 Clear c I
d 4 Decade Log from 2) d e
4 Decade Log from 1) e
Lin-Log Hybrid from 2)
Lin-Log Hybrid from 1)
3 Track All Clear
Track 4 Clear
Style 3 Wide, Depth on left Style
4 Wide, Depth on left
Dl Mo grid - 3 Track Linear, Track 1 Spiit [ei] No grid A
0 Borders but no grid Linear Resisti 0 Borders but no grid
20 2 sets with no grid AP Linear + Track 2 Split 2D 2 sets with no grid
=4 4 lingar divisions 4 Clear Wide, Depth on left Txd 4linear divisions
xb 5linear divisions Gravel Pack x5 5 linear divisions
b0 10linear divisions Half Width 3 Track Linear
Tllnh  10linear divisions - no horizontal lines Depth + 5 Linear tllnh 10 linear divisions - no horizontal lines
belnh 16 linear divisions -no horizontal lines 5 Track Sector Bond Ixl6nh  16linsar divisions - no horizontal lines
T2h 20 linear divisions Star-Jet 1x20 20 linear divisions
210 2 sets of 10linear divisions Depth + 4 Linear 210 2 sets of 10 linear divisions
x5 3 sets of 5 linear divisions Pipe Tally Log 35 3 sets of 5linear divisions
210log1 2 decade log, starting at 1 210logl 2 decade log, starting at 1
210log2 2 decade log, starting at 2 210log2 2 decade log, starting at 2
10logl 3 decade log, starting at 1 c10logl 3 decade log, starting at 1
310log2 3 decade log, starting at 2 3cl0log2 3 decade log, starting at 2
4x10logl 4 decade log, stating at 1 b 4x10og1 4 decade log, starting at 1 e
== = H = = = = =
L1 L L = HH = H i
a @ b — € 1 c a @ b — d — c
= ] ] o =t i i i
= B e T F—F—F
—t— Tt Tk T 1 —H = -

Fig. 6.28 Layout Grid Editor

6.2.1.1 Layout Grid Editor - Editing tracks

The width of the layout goes from 0 on the left to 100 on the right. When the log is plotted, the presentation
will cover the width of the plotter regardless of the plotter width. Each track can be specified to be any width
and be placed in any position on the page. When the track is highlighted in the Tracks column any of the
existing grid styles may be applied to that track.
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Fig. 6.29 Editing an existing layout

Tracks may be added or removed from the layout by clicking on Track -> Add ( or -> Delete). By clicking on
the [Redraw grid] button, the grid track changes that have been made.
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Fig. 6.30 Adding or Deleting Tracks
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6.2.1.2 Layout Grid Editor - Editing List of Layouts

Grid Layout list of displayed grid

layouts.

By clicking on the User can edit the

‘Grid Layout | Track
Rename }kﬂ Tracks Lt Right Color

e Delete
St B o 10 ; =
= < I O CPa——
3T ar c . |
4 Decade Tog g
Lin-Log Hybrid {from 2} f

Lin-Log Hybrid from 1}
3 Track Al Clear
Track 4 Clear

3 Wide. Depth on ef Siyle
Fig. 6.31 Editing the list of grid layouts

By clicking on “Rename”, the current name of the grid selected will be shown. By typing the new name of

the irid in the box and selectini [OK] the irid will be renamed.

Mew grid title
5 Track Sector Bond

Cancel | ok |

Fig. 6.32 Renaming a grid layout

If “Delete” is selected, a verification window will open to confirm the deletion and to prevent accidental
deletions. If [Yes] is clicked, the selected layout will be deleted from the list.
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Fig 6.33 Deleting a Grid Layout

If “Copy” is selected, a window will open that the User can type a name for the new layout that will be
generated when the existing layout selected is copied. This new layout will then appear at the end of the
current list of layouts.

Mew grid title

Cancel | ok |

Fig. 6.34 Enter new title for copy of existing layout

If “Move” is selected, the User will be allowed to move the selected layout to any position in the list of
layouts. The “Move Grid Layout to” window will open. By selecting a position in the list, the currently
selected layout will be moved to that position and all layouts from that position will be moved down.
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Fig. 6.35 Moving a Layout in the list of Layouts

6.3 Format Editor — Object

By selecting “Object” from the Format Editor the User has several options. The first is “Add Data”. This is
the same as clicking the [Add] button and allows the User to add information to the presentation. If an item
has been selected, the “Change Current Selection” and “Remove Current Selection” choices have the
same effect as the [Change] and [Remove] buttons.
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Fig. 6.36 Object Selection of Format Editor

The “Select Data or Shading” Selection allows the User to select any item that has been added to the
presentation showing the DB Item type and the Warrior mnemonic. If it is shading, the left and right
boundaries will be shown. Once selected the item may be changed or removed.
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Fig. 6.37 Selecting Data or Shading

6.3.1  Format Editor — Object — Add Shading

Shading may be added to a Warrior Format presentation by selecting “Object -> Add Shading”. The left and
right boundaries may be any plotted curve or a constant value of a curve to set the position in the track
where the curve is plotted.
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Fig. 6.38 Adding Shading

In the example shown in Fig. 6.38, the left boundary is set to a constant of 10 in the GR track, so if the GR
scales were 0 to 100 then the shading would occur from 1 division in the GR track on the left to the GR
curve on the right.
Be aware that it is the position of the curve in the track that is being shaded, not the
' Warning! value of the database item. The use of wrapped curves may cause unexpected
. S results when shading. As an example if you have a GR from 0 to 100 as a curve and
you wish to shade from a GR constant value of 100 to the curve, you will get no
shading since the GR has to wrap to get to the greater than 100 value. To shade something like an off
scale Gamma Ray, a second instance of the GR data item should be added (the user may want to use
different lettering to identify the curve, such as Gr or gr) to the plot with the appropriate off scale left and
right values with no wrap and then shade that curve from a constant that is the left boundary to the curve as
the right bounardy.
There are 25 different styles of shading that can be used. Note that there is a horizontal scroll bar to provide
access to all of the different patterns available. The color of the shading can be selected by clicking on the
drop down list labeled as “Foreground:” If “See Through” is not checked, then the shading will cover all of
the presentation behind it. If “See Through” is checked, then grid lines and curves will show through behind
the shading pattern. A label may be used to identify the shading in the format editor. Not that the label does
not show on the plot itself unless it is selected in the Options, as discussed shortly.

6.4 Format Editor — Color Maps

Color maps are used to present variable density, 3D Images, and some pattern strips in Warrior. Each
printing device and the screen can have its own presentation for a color map. If no presentation is available



for the device, the software interprets the screen presentation and uses it for the device. The User can
create and/or edit his own color maps by clicking on “Color Maps -> Edit” from the Format Editor.

File Layout Ohject | Color Maps | Options

6.4.1  Format Editor — Color Maps — Creating and Editing
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Fig. 6.40 Color Map Editor

To create a new color map, first click on the device or screen that you want to create the color map for.
Then click the [New] button to ensure a new map. Now click the [Add] button to bring up the Windows color
palette. You can select any color and /or adjust the settings for the color. When you click [OK], that color will
be added to your color map. You can continue adding colors, with each additional color placed to the right
of the existing ones.
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Fig. 6.41 Windows color palette

At any time, on new or existing color maps, if you click on a color and click [Change], that color can be
edited again to replace the existing color.

Similarly, by clicking on a color and clicking the [Remove] button, that color can be removed from the color
map. Care should be taken when doing this as the [Remove] button will give the option to remove the color
map if no color has been selected for removal.

The [Reverse] button allows the User to reverse the order of the colors shown in the color map.

The [Blend] button can function in two different ways. If the “count” box has a number in it, then clicking on
[Blend] will cause that many new shades blended between the existing colors to be inserted between every
pair of colors. If no count is in the box, the colors will be blended to a maximum of 256 different shades of
colors.

Clicking the [Save] button will save any changes made to existing color maps (same as . The [Save As ...]
button will allow the User to save the color map with a new name that will then appear in the colormaps list.
[Close] will close the color map editor reminding the User of any unsaved changes.
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Fig. 6.42 Blending colors in color map

6.4.2 Restoring Color Maps from other systems

The Warrior 8 software now allow for the transferring of color maps between systems. On the system that
has the color maps that you wish to use, go to Warrior Backup and do a backup to a file. Transfer the file to

the system that you want to put the color maps on, and then run Warrior Backup on it.
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Fig. 6.43 Using Warrior Backup to backup files from a system

Go to the Restore page and use the [Browse] button to select the file. Click the [Advanced >>] button to see
a list of the files in the backup file. Uncheck the uppermost check box to un-select all files in the backup.
This prevents doing a complete restore from the first system. Click on the [+] beside configuration. Click on
the [+] beside Color Maps. You should now see the list of color maps from the first system. Check the box
beside each color map that you wish to restore.
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Fig. 6.44 Restoring Color Maps



6.5 Format Editor — Options

The options that are available in the Format Editor are to show a tool image on the side of the presentation
during logging passes. To show the shading labels in interactive plot and on prints, similar to what is shown
in the format editor. Bore Hole Image presentations can be attached to a presentation format so that when
the presentation is called up the borehole image presentation also come up provided valid data values are
available.

[~ When logging, show tool postion on Interactive Plot

[~ Show shading legend in log insert

BHImage presentation wipedl bhf ;! Cancel

Fig. 6. 45 Format Editor Options



