16 Cable Types and Filter Settings

The Warrior 8.0 Software now includes provisions for setting certain parameters for user defined cables.
These parameters include the line resistance for that line and filter settings for multiple user declared signal
types.

The line resistance setting for a line will be used in computing the Head Voltage Apparent output in all
services.

If a particular service has a signaltype control in the service, then when that service is ran the Warrior
Software will look for specific filter settings that have been saved for that signal type for the cable that is
currently selected.

16.1 Defining Cable Types

The first step in setting up the process to use different cable selections is to define a new cable by name.
The name can be any text string that the User wishes to identify that particular cable or type of cable. The
name may be something as simple as “Truck 1234 — 5/16 Line”. It may also be something more specific as
“1K22PZ — 7/32 (12000 ft. to 18000 ft.)

To declare a new cable, go to the Control Panel in the Warrior Program group. At the top of the window,
click on the Acquisition tab. The Cable type section is in the upper right hand corner of the Acquisition
sheet.
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Fig. 16.2 Cable type section of the Acquisition sheet of Control panel.

To add a new line, click on the [ Add ] button to bring up the New Cable Type Description window.
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Fig. 16.3 New Cable Type Description

Type in the new name or description that you wish to use to identify the cable then click [ OK ] to accept the
name.
16.1.1 Setting Line Resistance

Each of the defined lines may have a line resistance setting. Enter the measured resistance of the line,
then click the [ Set ] button to assign that resistance to the currently selected line. The line resistance is
used to compute a head voltage apparent output HVOLTA. This is calculated by multiplying the line
resistance by the Tool Current output to give a line voltage loss and then subtracting this from the Tool
Voltage output. HYOLTA = TVOLT — ( TCURR * Line resistance ).

Unless the line resistance is accurate and the tool voltage and current are properly calibrated then the head
voltage will not be an accurate measurement.



16.1.2 Defining Cable Signal Types

There are two different methods to set up signal types. The first are device signal types for certain
proprietary devices. When the device is called out in a service, the software will look for a cable filter setting
for the current cable.

The more common method comes from the SDSTIP device (Scientific Data Systems Tool Interface Panel).
The cable signal types for the SDSTIP are User defined types of signals, usually telemetry signal from the
tool that are filtered through the CBL1D board in the interface panel. If a signal type control has been added
to a service, the software looks for saved filter settings for that type of signal in the settings of the cable that
is currently selected in the Warrior Control Panel. If cable filter settings are found, it will use those settings,
otherwise a notification that no settings were found will be displayed and it will use the service default
settings.

The first time a cable is used with a signal type control in a service the settings will not be found and a
warning message will be shown. To save the filter settings for the currently selected cable, from Warrior
Logging System Acquisition window click on Edit -> Device Configuration -> SDSTIP. Click on the [Update
Cable Settings] button to save the filter settings for the signal type to the cable selected. The next time the
service is started, no error message is shown and the service default filters are used. To use the cable
signal type filters, you will need to edit the device configuration for the SDSTIP again and select to use the
cable type filters. That setting will be saved so that from then on the cable type filters will be used unless
Ehey are turned off in the SDSTIP settings.
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Fig. 16.4 Cable filter settings not found.
16.1.3 Example of Setting up Two Cables with different Filters for the same Service

| realize how convoluted all of this might seem to someone not familiar with the process. As an example to
show the procedure for getting a service to run different filter settings, | will give an example of a CSS
(Computer Sonic Systems) tool that has previously required two different services to run on different length
of lines.

16.1.4 Setting Two Example Cables

We will be making two lines. The first will be the short to medium line and the second will be the medium to
long line. To set up cable types we will need to go to the Warrior Control Panel Acquisition page. In the
Cable Selection area, click on the [ Add ] button to add a new cable.
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Fig. 16.5 Click to Add a new Cable.

When the Add new Cable Type window comes up, type in the description for the new cable type. Click the |
OK] button to accept the description.
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Fig. 16.6 Enter short to medium line description.
Click on the [ Add ] button again to add the second line. Type in the line description for the medium to long
lines in the text window. Then click on the [ OK ] button to accept the description.
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Next we need to set the line resistance for each line. From the control panel acquisition page cable
selection area, click the drop down list of cable selections and pick the short to medium line
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Fig. 16.9 Click Drop Down list to select cable.

For this example we will set the line resistance to 35 Ohm. Enter 35 in line resistance and then click the [

Set ] button.
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Fig. 16.10 Set Line Resistance for short to medium line to 35 Ohm.
Next, click the cable selection drop down list and select the medium to long line. We will put in an example
resistance or 70 ohms, and then we click the [ Set ] button to save that value.
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Fig. 16.11 Set Line Resistance for medium to long line to 70 Ohm.
Click the [ OK ] button at the bottom of the control panel Acquisition page to save changes.

16.2 Setting up Signal Types through the Service Editor

The next step is to add the Signal Type control to our services. From the Warrior Software program group,
select Database Utilities. From the Database Utilities, click on Edit Logging Service Details to bring up the

Service Editor.
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ig. 16.12 Starting the Service Editor from Databse Utilities.
In the Service Editor, click on one of our CSS services to edit it. We will start with the “CSSM 3 18" RBT
Short to Medium Lines” service. Then click on Add -> Control.
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Fig. 16.13 Select CSS Service and Add Control.

Scroll down the Control Keyword dropdown list to “Signal Type”. For this example we will enter “CSS_TEL”
as the Control value for the signal type. Note that any text string that the User chooses may be entered for
a signal type. SClick [ OK ] to save the setting. Click on File -> Save to save the edited service.
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Fig. 16.14 Set CSS Service signal type to CSS_TEL

We now have to add the same signal type control to the “CSSM 3 1/8” RBT Medium to Long Lines. Click
on the service to edit it. Click on Add -> Control. Select the “Signal Type” Control keyword and enter
CSS_TEL for the control value. Click [ OK ] to save the control value and then click on File -> Save to save
the edited service.

16.3 Setting Filter Settings for the Signal Types on each Line

Now we need to set the filter settings for the CSS_TEL signal for each line that we will be using. Go to the
Warrior Control panel Acquisition page, and in the Cable Selection area, click the dropdown list to select
the 5/16” — Short to Medium cable that we have already declared. Click [ OK ] to save.
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Fig. 16.15 Select Short to Medium line for use.
Now start Acquisition and select the “CSSM 3 1/8” RBT Short to Medium line” service. You will get a
message stating that you have incomplete filter setting for cable type. Click [ OK ] to cancel the message.
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To save the settings, Click on Edit -> Device Configuration -> SDSTIP.
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ig. 16.18 Edit SDSTIP to save filter settings

When the SDS Tool Interface Panel Configuration windows come up, Click on the [ Save As Cable
Settings ] to save the current values to the cable type. Then click [OK ] to close the window
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Fig. 16.19 Saving the filter settings to 5/16” — Short to Medium line

Now restart the “CSSM 3 1/8” RBT Short to Medium line” service and Edit -> Device Configuration ->
SDSTIP again. This time the Use cable Type Filters check box has been enable. Click on this box to use
the saved cable settings. This service now will use the saved cable filter settings every time until they are
changed by editing the SDSTIP configuration settings and unchecking the Use Cable Type Filters box.
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Fig. 16.20 Selecting to use the saved Cable Filter settings.

Now that we have set up a CSSM service to use the short to medium line settings, we have to set up the
medium to long lines service. Go to the Warrior Control panel Acquisition page and select the 5/16”
Medium to Long line. Then Click [OK ] to close the control panel and save the selected cable.
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Now go to Acquisition and select the “CSSM 3 1/8” RBT Medium to Long line” service. You will once again
get the warning message about incomplete filter settings for cable type.
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Fig. 16.22 Warning message for incomplete filter settings for cable type
From Acquisition, we need to once again Edit -> Device Configuration -> SDSTIP and Click the [ Save As

Cable Settings ] Button. Click the [ YES ] button to save the settings. Then click [OK ] to close the SDS
Tool Interface Panel Configuration Window.
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Fig. 16.23 Saving CSS_TEL filter settings for Medium to long line

Now from Acquisition, restart the “CSSM 3 1/8” RBT Medium to Long line” service. When the service is
loaded we need to edit the SDSTIP configuration by clicking again Edit -> Device Configuration -> SDSTIP.
Click the Use Cable Type Filters checkbox to bring in the saved cable settings. Then click [ OK ] to close
the SDS Tool Interface Panel Configuration window.
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Fig. 16.24 Using CSS_TEL filter settings for Medium to long line

If you look at the filter settings that were saved in Fig 16.20 and Fig 16.24, they were:

Sonic Fc Sync FcAux Fc
Short to Medium 6000 69 1000 HP
Medium to Long 6000 69 10000 BP

Now with Medium to Long lines selected in the Warrior Control panel, if you start Acquisition and select
either the “CSSM 3 1/8” RBT Short to Medium line” service or the “CSSM 3 1/8” RBT Medium to Long line”
service and then edit the SDSTIP configuration settings, you will find that both services are using the filter
settings for the medium to long lines. Likewise, if you change the selected cable in the Warrior control panel
to Short to Medium line, you will find that the short to medium filter settings are being used in both services.
At this point, you could use the Service Editor to Remove one of these two services and then rename the
remaining service to “CSSM 3 1/8” RBT".

If at a later date, it is decided that you need to change the filter settings of the service for a particular cable,
you would need to edit the SDSTIP Device Configuration and uncheck the Use Cable Type Filters check
box. The software will revert the filter settings to what is saved in the service. Make any changes that you
need and then [ Update Cable Settings ]. Restart the service and edit the SDSTIP device configuration to
check the Use Cable Type Filters check box.



